admiralty image

ADP and AENP Updates via e-Mail unavailable

Incident Report for Admiralty

Resolved

This incident is now resolved
Thank you for your patience
Posted Mar 20, 2025 - 11:49 GMT

Update

Due to a technical issue with external e-mails updating via e-mail for ADP and AENP is currently unavailable.

PAYS and SENC Reporting is not currently been received.

All response e-mails from Fleet Manager are processing and you should be receiving order confirmations for all products.

Please note our Customer Services Team are unable to receive e-mails currently, but are available via the Customer Service Portal and telephone.

We apologise for any inconvenience caused.
Posted Mar 20, 2025 - 08:54 GMT

Investigating

Due to a technical issue with external e-mails updating via e-mail for ADP and AENP is currently unavailable.

Please note our Customer Services Team are unable to receive e-mails currently, but are available via the Customer Service Portal and telephone.

We apologise for any inconvenience caused.
Posted Mar 20, 2025 - 07:23 GMT