admiralty image

AVCS Ordering

Incident Report for Admiralty

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 13:21 GMT

Update

We are continuing to investigate this issue.
Posted Feb 20, 2026 - 08:37 GMT

Investigating

Due to unforeseen circumstances we are aware of some AVCS orders failing via Fleet Manager and B2B.

We are working hard to resolve this issue, please check back shortly for updates.
Posted Feb 20, 2026 - 08:33 GMT
This incident affected: B2B - AVCS (SubmitOrder) and Fleet Manager (Order AVCS).